Registrieren  |  FAQ  |  Suchen  |  Mitgliederliste  |  User MapGEO Map  |  Benutzergruppen  |  Login   | Album 
Neue Antwort erstellen
 EOS 7d Mk II mit Tablet/Smartphone verbinden 

Forenlevel: Hobbyfotograf
Forenlevel: Hobbyfotograf
Anmeldungsdatum: 25.03.2013
Beiträge: 5
Antworten mit Zitat
Hallo zusammen

Ich habe ein Problem mit dem Verbinden der o.g. Kamera mit Tablet oder Smartphone (Android). Die Kamera hat ein USB 3.0-Kabel und ich verwende einen OTG-Adapter (2.0). Leider wird die Kamera nicht erkannt.
Das Tablet ist ein Nexus 7 und das Smartphone ein Samsung Galaxy 4. Mit anderen Kameras wie 100D, 50D 1100D funtkioniert die Verbindung, nur nicht mit der 7D. Auch habe ich schon andere Kabelkombinationen ausprobiert, sprich anderes USB-Kabel und anderes OTG-Kabel.

Was mache ich denn falsch?

Ergänzung: die Camera kann ich mit dem Computer verbinden.

Gruss,
Marlene
Offline Benutzer-Profile anzeigen Alle Beiträge von msteinmann anzeigen Private Nachricht senden
 Re: EOS 7d Mk II mit Tablet/Smartphone verbinden 

Forenlevel: Fotokünstler
Forenlevel: Fotokünstler
Anmeldungsdatum: 10.03.2011
Beiträge: 520
Antworten mit Zitat
msteinmann hat folgendes geschrieben:
Die Kamera hat ein USB 3.0-Kabel und ich verwende einen OTG-Adapter (2.0).


Falls die Verbindung rein über USB zustande kommen soll, hätte ich folgende Hypothese:

Normalerweise arbeiten Smartphones nicht als USB-Master (wie ein PC), sondern in der USB-Slave-Rolle (wie eine USB-Platte oder ein anderes USB-Peripheriegerät).

Zur Umkehrung der Rollen ist nicht nur ein entsprechender Hardware-Adapter, sondern je nach Betriebssystem eventuell auch ein entsprechender Treiber und/oder eine Einstellung erforderlich, in welchem Modus die USB-Schnittstelle zu betreiben ist. Daneben gibt es teilweise auch eine automatische Hardware-Erkennung, die jedoch mit den richtigen Konfigurations-Dateien / Hardware-Datenbanken mit USB-Geräte-Ids etc versorgt sein sollten.

Ferndiagnosen auf diesem Gebiet sind schwierig. Wenn ich das Gerät vor mir hätte und es gerootet wäre, würde ich mich mit adb einloggen und Linux-Tools wie lsusb verwenden, um den Fehler einzugrenzen, oder notfalls von Hand in /proc/ oder /sys/ nachsehen.

Falls ein Fehler auf dem Gebiet der USB-Geräteerkennung vorliegen sollte, hilft im Endeffekt nur ein Software-Update des Betriebssystems bzw entsprechender -Komponenten auf die neueste Version.
Hidden Benutzer-Profile anzeigen Alle Beiträge von athomux anzeigen Private Nachricht senden
  

Forenlevel: Fotograf +++
Forenlevel: Fotograf +++
Anmeldungsdatum: 04.02.2008
Beiträge: 5446
Wohnort: Augusta Treverorum
Antworten mit Zitat
Hallo Marlene,

vielleicht mal das Tool, OTG-Troubleshooter aufs Tablet ziehen und probieren.
Guckst Du.

Gruß Roman Wink

_________________
5DMK3, A6000, A7II, Glas, Licht, Stativ, Rucksack, Kleinkram
Hidden Benutzer-Profile anzeigen Alle Beiträge von NoPogo1960 anzeigen Private Nachricht senden
  

Forenlevel: Hobbyfotograf
Forenlevel: Hobbyfotograf
Anmeldungsdatum: 25.03.2013
Beiträge: 5
Antworten mit Zitat
Hallo Ihr Lieben

Vielen Dank für Eure Hilfe.

Wie die Geräte arbeiten ist mir mehr oder weniger klar. Hat bisher auch immer funktioniert. Ich verwende dafür ein OTG-Kabel von Samsung (Tabletseitig) und das Mitgelieferte USB-Kabel von Canon. Zuerst hat diese Kombination nicht funktioniert. Dann habe ich das Canon-Kabel gegen ein anderes USB-Kabel (von einer ext. Festplatte) getauscht, und dann hat es zwitweise funktioniert, und dann plötzlich nicht mehr. Dann habe ich die Verbindung mit einem Samsung-Smartphone ausprobiert. Das ging dann auch ein paar mal, und plötzlich nicht mehr.

Nun habe ich festgestellt, dass es auf diesem Weg funktioniert: Kamera an -> Kabel mit Tablet verbinden. In dieser Reihenfolge kommt dann die Verbindung (meistens) zustande.
Ich verstehe das nicht warum, das so ist. Die anderen Kameras werden sofort erkannt.

Das OTG-Tool hat übrigens auch geholfen.
Offline Benutzer-Profile anzeigen Alle Beiträge von msteinmann anzeigen Private Nachricht senden
  

Forenlevel: Fotokünstler
Forenlevel: Fotokünstler
Anmeldungsdatum: 10.03.2011
Beiträge: 520
Antworten mit Zitat
msteinmann hat folgendes geschrieben:
In dieser Reihenfolge kommt dann die Verbindung (meistens) zustande.
Ich verstehe das nicht warum, das so ist. Die anderen Kameras werden sofort erkannt.


Ich tippe auf Race-Conditions (zeitliche Abhängigkeiten) beim Wettrennen zwischen Treiber-Aktivierungen sowohl auf dem Smartphone als auch in der Kamera (und als drittem Teilnehmer beim USB-Protokoll), also letztlich Bugs in der Software.

Solche Bugs sind oft unsystematisch und unlogisch. Ein Betriebssystem- bzw Firmware-Update kann helfen, muss aber nicht, oder kann es auch verschlimmern. Ist einfach vom Prinzip her ein Lotteriespiel, solange der Fehler nicht grundsätzlich gefixt ist.
Hidden Benutzer-Profile anzeigen Alle Beiträge von athomux anzeigen Private Nachricht senden
Du kannst keine Beiträge in dieses Forum schreiben.
Du kannst auf Beiträge in diesem Forum nicht antworten.
Du kannst deine Beiträge in diesem Forum nicht bearbeiten.
Du kannst deine Beiträge in diesem Forum nicht löschen.
Du kannst an Umfragen in diesem Forum nicht mitmachen.
Du kannst Dateien in diesem Forum nicht posten
Du kannst Dateien in diesem Forum herunterladen
Alle Zeiten sind GMT + 1 Stunde  
Seite 1 von 1  

  
  
 Neue Antwort erstellen  

Traumflieger-Video: Hähnel Combi TF per Funk Kamera auslösen und blitzen (100m) !  kabellos blitzen mit dem Slave Flash - neuer Traumflieger-Report !  das Profihandbuch zur Canon EOS 60D !